Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2007
    Location
    running springs, ca
    Posts
    467

    Default oil injection system LT-80

    does the oil injection system on this bike run off vacuum through the carb?
    How do i test for oil flow? Theres very little or no flow of oil when just spinning the starter.
    Please help were trying to get out to ride this wekend!!!!!!!

    Thanks,
    Russ

  2. #2
    Join Date
    Nov 2006
    Location
    Indiana
    Posts
    1,367

    Default

    Most oil injectors are run off a small pump from the cranks rotation that is connected to the throttle. IMO they are junk. Premix the fuel and put it into the tank and you know the motor will have oil/gas. Find the tube that enters the carb and block it off and then also drain and block off the oil tank itself or remove it. Then later chase all the other parts from the throttle to the pump itself and remove it. They work good when new but after time they plug up and or stop working.
    My bikes

    Foster Bike
    00' Banshee (Shit my buddy don't ride it!)

    84' FXE Shovelhead

    72' Norton Chopper

  3. #3
    Join Date
    Aug 2007
    Location
    Hartville,OH
    Posts
    48

    Default

    The Oil Injection Systems work great, leave it alone!!
    They run off it's own Oil Pump Set-Up!!
    I use Factory Suzuki Pre-Mix Oil and have never had any problems.
    1987 Suzuki LT500R Quadracer (a.k.a. StepZilla)
    - Rx Q-Pipe - Rx Carburetor - Rx Heatseeker - Rx Head
    - Stadium Shocks - LSR Swinger - LSR Axcalibar Axle
    - ITP Double Beadlock Rims - DuraBlue Rear Axle Hubs
    - PRM Summit Bumper - PRM Desert Grab Bar - Burgard A-Arms On The Wish List