Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Join Date
    Oct 2006
    Location
    CA
    Posts
    2,395

    Default killswitch not working

    i just picked up a 95 banshee
    and my killswitch doesnt work
    and i can fire the bike up on the off position aswill and the headlights arent plugged up so i cant tell if the light button works or not
    bike fires up fine and runs great but the killswitch doesnt work
    and ya there is no key on it
    im not sure if the 95 banshee came with a key
    86 trx310r

  2. #2
    Join Date
    Sep 2007
    Location
    North Carolina
    Posts
    5,668

    Default

    I have seen guys unhook those before. I know it sounds crazy, but I have heard of it being done.
    Support our site>> E2S Premium Membership

    E2S MOD

  3. #3
    Join Date
    Oct 2006
    Location
    CA
    Posts
    2,395

    Default

    all i want is a running killswitch and light switch
    the killswitch is plugged into the wireharness that leads to the cdi box
    everything is plugged the only thing not plugged up is the head lights
    ive ran all the wires and everything is plugged up
    so i figure the killswitch botton is fried and i need a new one
    86 trx310r

  4. #4

    Default

    If you can't fix it, A tether kill switch is like 30 bucks. They work just as good as the regular ones but Keep the bike from running away on you if you bail.
    "Fear the 5"

  5. #5
    Join Date
    Oct 2006
    Location
    CA
    Posts
    2,395

    Default

    i still want to run the front headlights ,and i dont like killing the bike in gear becouse the switch dont work
    the bike has no tors its all removed but i did noticed the tors black box is still connected to the main wire harness
    86 trx310r

  6. #6

    Default

    Possibly a Ground issue? Try Completing the circuit manually in the switch.

  7. #7
    Join Date
    Oct 2006
    Location
    CA
    Posts
    2,395

    Default

    how would i go about doing that
    take the switch off and holding a peice of middle to the inside of the switch
    kinda makes since becouse i dont think the inside of the switch is rubbing the bar at all
    86 trx310r

  8. #8
    Join Date
    Sep 2007
    Location
    North Carolina
    Posts
    5,668

    Default

    Quote Originally Posted by trx View Post
    how would i go about doing that
    take the switch off and holding a peice of middle to the inside of the switch
    kinda makes since becouse i dont think the inside of the switch is rubbing the bar at all
    Bro, I just got rid of a switch. If you had caught me about a week earlier I would have gave it to you.
    Support our site>> E2S Premium Membership

    E2S MOD

  9. #9
    Join Date
    Oct 2008
    Location
    Anderson, Indiana
    Posts
    2,839

    Default

    Yep.......something tells me that this one has custom or aftermarket bars on it and the person who owned it didn't care if the kill switch worked or not. Try fooling with the ground and make sure it is grounded would be my second move after verifying the wiring to the CDI which you have already done.
    If it ain't broken yet, you ain't tryin' hard 'nuff.

  10. #10
    Join Date
    Jan 2005
    Location
    Virginia
    Posts
    13,047

    Default

    im sure i've got one in the garage somewhere. if you cant get it to work let me know, and i'll dig it up. it's yours if you just pay the shipping.